PDA

View Full Version : Running Rough


Fords4ever
June 15th, 2016, 08:42 PM
First time posting have a bit of a problem with my old truck(not really old):smilez: I have been getting it back up running again after moving back to CA from AZ. Was having some very rough running issues under load.

Started with MAF cleaning , Cleaned throttle body and EGR,IAT and it started running a bit better still sluggish on acceleration , so I changed out the Fuel filter , Air Filter , Oil and filter.... and still has a sluggish get up , spark plugs where replaced about 2000 miles ago , and its not throwing any codes or CELs. anyone have any advice on this one ?

Thanks
Ken

glc
June 15th, 2016, 11:51 PM
What exactly is your truck? Engine and transmission? Coil pack or COP? What brand plugs did you use? Have you tried Techron in the gas? Maybe a compression test? If it was sitting for a while, have you burned out the old gas and filled it with fresh gas yet?

Fords4ever
June 16th, 2016, 11:46 AM
99 f150 4.6 Windsor, 2wd, 4r70w trans, replaced plugs 9 months ago with motorcraft but didn't do wireset going to grab a new set today. replaced old k&N air filter was not fitting tight, cleaned EGR , cleaned throttle body and IAT, cleaned MAF , checked all vacuum hoses no cracks or holes and all on proper places, Replaced Fuel filter ..... was trying to replace the cheap easy stuff first. ohh yea did a techron cleaner also. have not doing comp check as of yep. don't have the tools for that. oh and its 2 coil packs not COPs , and had added new gas recently.

glc
June 17th, 2016, 09:32 AM
K&N filters can foul the MAF with oil. They also do not filter as efficiently as a dry paper filter and let a lot more fine dust through.

Fords4ever
June 17th, 2016, 12:03 PM
YES the old truck is back , after pulling the number 4 spark plug wire out it was almost ripped in half no clue how that happens. but it is back up and running great . Thanks GLC Yes the K&N is a problem for those MAF coils were packed with oil and very nasty Fram one I have NOW fits a lot better also hand to clean the inside of the housing out it had so much crap in it..

Thanks again
ken:smilez:

gwfan
June 23rd, 2016, 03:42 PM
What did you replace the K&N's with?

JSoko
June 23rd, 2016, 08:59 PM
I think most of the problem with the K&N is the person doing the cleaning/oiling

I've been using that type for 10 years in my '06, no issues