Ford Truck Club Forum

Ford Truck Club Forum (http://www.fordtruckclub.net/forum/index.php)
-   1992-1996 Ford F150
(http://www.fordtruckclub.net/forum/forumdisplay.php?f=93)
-   -   92-96 Cam Upgrade (http://www.fordtruckclub.net/forum/showthread.php?t=862)

nine5flareside August 8th, 2009 09:33 AM

92-96 Cam Upgrade
 
Has anyone ever upgraded their cam in a 1992 - 1996 302 5.0 F-150?

JSoko August 10th, 2009 04:36 AM

did you see my post in Modified??

chatterjj November 13th, 2009 07:36 PM

:seeya: 95 f150 4x4 5.0L STOCK
i just put in a E303 cam and new roller lifters.
i ordered the kit from summit. http://www.summitracing.com/parts/CMB-08-0029/
bought the ford racing cam and the ford racing lifters to match it. one thing i would do different tho is the kit comes with a MR Gasket ((gasket set jmho cheap.)) buy the gaskets separate get the factory style valve cover gaskets / intake / water pump / timing cover / oil pan thermostat. the Mr gasket set is cork the factory set has the metal with neoprene. plus they sent me 3 water pump gaskets and none of them fit my truck lol. my water pump takes 2 gaskets one for the back plate and one for the block. get a new t-stat. antifreeze.
check end-play with the new cam, make sure ya have-----no more no less.
0.001 - 0.007 inch, lol i guess the hardest thing to me about this whole installation was the 30mm torq's screw in the dead center of the intake plenum. tough to get to if ya got big hands. you can look online for a spec and installation sheet from summit they didn't send one with my parts. timing depends on what ur looking for . for sound or hp. took me a few runs around the block to get mine where i wanted it. if ya need anything just holler. its an easy install. took me about 16 hours to complete with all the cleaning and gasket removal. but im slow anyway lol thing is i didnt want to go back into it. needed it right the first time.

nine5flareside November 13th, 2009 07:59 PM

Thanks for the info Chicken Chatter! Stock pushrods? Did you remove the block to install this?

chatterjj November 14th, 2009 11:11 AM

everything in my engine is stock other than the new cam and lifters. yes same rods. same heads. i did change the t-stat and put in a new temp sensor. i did all the work under the hood.
i didn't remove the block or the heads. removed the rad- and shroud, took the ac/power steering loose and tied them back to the fender well. same on the other side with the alt- and smog.
took out my grill. jmho cover ur bumper so not to scuff it. i forgot to do this and i had a hard time working the scuff marks off the chrome. only thing is im 44 years old now lol and my back isn't what it use to be, working under the hood of a truck and i did most of the work sitting on the rad- support can be tough. but id do it again it was well worth my time an pain lol.

nine5flareside November 17th, 2009 03:03 PM

OK Just ordered that e303 cam and did a little more product research. Chatter, when you are driving at low speeds in the truck it is said that it will feel like you are in second gear. I was told that I shouldnt buy this cam (the one you got) and put it in my truck unless I get a new stall converter in the 3000 range. You have the cam in your truck so how does it feel when you are driving rather slow?

chatterjj November 18th, 2009 01:06 AM

well i have no problems with idle, in or out of gear. driving at low speeds, no problems. no stall converter. i didn't change anything but the cam and lifters in my 5.0L ENGINE. the TRANSMISSION and torque converter same as it came from the factory.
jmho i asked around before i changed out the cam. i had several people tell me not to change the cam to do heads or have the heads worked for more hp. it could be true that id have gotten more hp with the head work, but that's not the main reason i changed it. i wanted more mid to top end power for out on the road. and that's what i got with the E303 cam.
i will say this, you will have to find a....... how do i put it, happy medium with power and sound ur looking for. took me about 3-4 laps around the block to get mine set where i had the sound i wanted along with the power.i could run mine up a bit more and have more bottom end power, but when we did that i lost the sound/lope i wanted. so now im about the same as before the cam up to about 2500-3000 rpm then its like a power-band kicks in and throws ya back in the seat lol. sounds like its gonna suck the hood in through the engine. its not the fastest by any-means but i like it, i got the sound/lope i wanted and more mid to top end power. i have no regrets about doing the cam change. been trying to talk the wife into letting me put a E303 in her 03 5.0L expedition lol.

nine5flareside November 18th, 2009 01:14 AM

When you say you got it set to how you wanted it... how exactly did you set it?

chatterjj November 18th, 2009 08:39 AM

when we first did the install we just made sure we had # 1 tdc & all marks in line.
when we started the truck up we just had the timing set in the general area and the bolt snugged down but still lose enough to bump with my hand.
got it running and it started easy enough. adjusted it at that time to sound/lope a lot of lope. checked it with the gun an set it at 14, when i drove the truck it was very weak no power.
so then with the timing light and set it at i think 12 still a bit weak but better. next we tried 11, still not what i wanted. as of now with the timing light i locked mine down at 10.
dont forget to pull the spout before ya try to set it with the timing light. after its set put the spout back in.


All times are GMT -4. The time now is 05:58 PM.



FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. FordŽ is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.