Ford Truck Club Forum

Ford Truck Club Forum (http://www.fordtruckclub.net/forum/index.php)
-   1987-1991 Ford Bronco
(http://www.fordtruckclub.net/forum/forumdisplay.php?f=119)
-   -   High idle (http://www.fordtruckclub.net/forum/showthread.php?t=10500)

Moore1991bronco December 1st, 2014 06:57 PM

High idle
 
A pieced together motor in a 91' Ford Bronco, has A set of GT 40 heads off of a '96, 5.0 Ford Explorer, has a '96 5.8 EFI motor. It idles high at around 1500 RPMs, and when you give it gas, the RPMs go up but it takes a long time for them to fall back to 1500 after releasing the throttle. I recently put the GT 40 heads, new gaskets, and did an at-home port and polish on the heads. I can't figure out why it would be idling so high, because it didn't when I started this project. Any help is appreciated.

skatebowd December 1st, 2014 10:44 PM

have you checked for vacum leak

Moore1991bronco December 1st, 2014 11:09 PM

I tried spraying brake cleaner around where I thought it might be sucking air

Moore1991bronco December 3rd, 2014 09:13 PM

Well I got it running like it should be it was a broke ear on the plenum and changed the gasket so it must have been sucking air where the ear was broke thank you for all the help

JSoko December 4th, 2014 01:27 PM

I spray with water

TCBronc90 July 17th, 2018 06:36 PM

Is this the correct spot to ask a similar question about high idle? Thanks, TCBronc90

glc July 17th, 2018 11:30 PM

We do prefer if you start a new thread in the appropriate forum. Thanks!


All times are GMT -4. The time now is 02:14 PM.



FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. FordŽ is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.