Quantcast Oil problem - Ford Truck Club Forum




Home






Forum






Gallery






Garage






Blog






Arcade






Settings






New Posts






TOTM






Vote




Remember Me?
       Join for free!




Search






How-To's






Unanswered






FTC Toolbar






Social Sites






Register




 
Ford Truck Club Forum > FORD F-100 | F-150 SERIES > 1973-1991 Ford F150



Welcome to FordTruckClub.net
Welcome to FordTruckClub.net, the internet's premier Ford truck community! You are currently viewing our boards as a guest which gives you limited access to view discussions and access other forum features. By joining our free online community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple, and absolutely free so please, join our community today!

Forgot your password? click here.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

 
Thread Tools Display Modes
  #1  
Old November 25th, 2018, 10:40 AM
sammyd's Avatar
sammyd sammyd is offline
 

Join Date: Nov 2011
Posts: 3
Likes : 0
Liked 0 Times in 0 Posts
Default Oil problem

I have a 77 400 rebuilt in my truck. Ran great at startup now blowing oil past filter gasket. Is there a passage blocked or what? Any help is appreciated
  #2  
Old November 25th, 2018, 11:41 AM
glc's Avatar
glc glc is online now
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,103
Likes : 2
Liked 98 Times in 95 Posts
Default

I'd suspect a defective oil filter or the wrong filter was used. Use a Motorcraft FL1A.

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS
  #3  
Old November 25th, 2018, 12:15 PM
sammyd's Avatar
sammyd sammyd is offline
 

Join Date: Nov 2011
Posts: 3
Likes : 0
Liked 0 Times in 0 Posts
Default

Used motorcraft fl1a and two other brands, same result, never had this issue before. Was good for a few minutes and then it blows gasket on front side of filter. Didn’t know if there’s a bypass valve or blockage on engine side?


Thread Tools
Display Modes


(View-All Members who have read this thread : 3
glc , harrison28 , sammyd

Similar Threads
Thread Thread Starter Forum Replies Last Post
a/c problem Arizona kid 1948-1983 Ford F100
0 June 1st, 2017 08:16 PM
97 F-150 4.6l esof problem trout12 1997-2003 Ford F150
1 December 17th, 2014 05:06 PM
Odd problem 88 f250 5.8 2Customs 1987-1991 Ford F250 | F350
3 February 25th, 2014 05:35 PM

Tags
oil , problem

Forum Jump









FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. Ford® is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.