Quantcast 92 F150 5.0 E4OD Not Shifting Code 625 - Page 2 - Ford Truck Club Forum




Home






Forum






Gallery






Garage






Blog






Arcade






Settings






New Posts






TOTM






Vote




Remember Me?
       Join for free!




Search






How-To's






Unanswered






FTC Toolbar






Social Sites






Register




 
Ford Truck Club Forum > FORD F-100 | F-150 SERIES > 1992-1996 Ford F150



Welcome to FordTruckClub.net
Welcome to FordTruckClub.net, the internet's premier Ford truck community! You are currently viewing our boards as a guest which gives you limited access to view discussions and access other forum features. By joining our free online community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple, and absolutely free so please, join our community today!

Forgot your password? click here.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

 
Thread Tools Search this Thread Display Modes
  #11  
Old July 18th, 2019, 08:55 AM
glc's Avatar
glc glc is online now
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,138
Likes : 2
Liked 112 Times in 108 Posts
Default

If the truck starts with the old one, that tells you that the new one is defective.

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS
  #12  
Old July 27th, 2019, 12:25 PM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Default Update

Put the old one back in and it fired right up. Returned the bad one and they sent a replacement. Put the replacement in and it fired right up. The transmission is shifting smoothly and is working now. The only fault code I have now is 173 HEGO (HO2S) sensor fault/rich. What can cause this fault?

Thx for all of your help with this.

92 F150 XLT 2WD 5.0 302 E4OD long bed
  #13  
Old August 3rd, 2019, 10:29 AM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Default Code 173 and 334

Still have codes 173 and 334. Performance is sluggish. Any ideas what to look for?

92 F150 XLT 2WD 5.0 302 E4OD long bed
  #14  
Old August 3rd, 2019, 11:27 AM
glc's Avatar
glc glc is online now
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,138
Likes : 2
Liked 112 Times in 108 Posts
Default

The 334 is EVP sensor - that's EGR valve position sensor. The EGR system needs to be troubleshot. The 173 might be a bad O2 sensor, but it's more likely it's running excessively rich due to too much fuel or restricted air. I'd go get the cat tested for excessive backpressure.

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS
The Following User Likes This Post:
harrison28 (August 5th, 2019)


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


(View-All Members who have read this thread : 55
67 Merc 4x4 , AlfredHof , Anthonysib , Bettybuiny , Billygenna , BrianRed , Danielfuh , Deannanob , DennisPoili , DennisTed , ErnikaOdowl , Eurosse , FrankCoosy , GeorgeEtela , glc , harrison28 , her , Jeffreytep , Jesseplosy , jheat , KeithFoult , Ken , Kennethdof , KevinDuels , LadonnaCen , LarryVab , LilaBar , MarioDit , MarioThoky , Martynaw , Michaelanify , Michaelrar , Mikaelhiz , nydon , Petrrarc , Pharmacevtmi , PollyTek , Ramonvog , RobertEmavy , Robertnut , RobertSnubs , RobertVog , RobertVoT , Rodneyvat , RonaldFon , Russellasymn , Shanehib , TimothyNut , TorqueO , TravisAvell , Wes , Williamidons , Williamsnort , XRumerTest , ZacharyThync

Similar Threads
Thread Thread Starter Forum Replies Last Post
AOD or E4OD? harrison28 Garage Talk: Engine & Drivetrain 6 January 14th, 2019 12:13 PM
e4od tranny shifting hard moemoe3 1992-1997 Ford F250 | F350
2 September 17th, 2014 11:48 PM
Speedometer & odometer off/ shifting hard LilBit 4x4 1992-1997 Ford F250 | F350
4 July 25th, 2013 07:43 PM
Truck shifting hard Monster 2004-2008 Ford F150
4 February 1st, 2013 03:19 AM
Shifting problem? russ94 2004-2008 Ford F150
3 February 11th, 2012 10:09 PM

Tags
625 , clicking , code , constantly , e4od , f150 , relays , shifting

Forum Jump









FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. Ford® is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.