Quantcast Gauge issues - Ford Truck Club Forum




Home






Forum






Gallery






Garage






Blog






Arcade






Settings






New Posts






TOTM






Vote




Remember Me?
       Join for free!




Search






How-To's






Unanswered






FTC Toolbar






Social Sites






Register




 
Ford Truck Club Forum > FORD F-100 | F-150 SERIES > 1948-1983 Ford F100



Welcome to FordTruckClub.net
Welcome to FordTruckClub.net, the internet's premier Ford truck community! You are currently viewing our boards as a guest which gives you limited access to view discussions and access other forum features. By joining our free online community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple, and absolutely free so please, join our community today!

Forgot your password? click here.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

 
Thread Tools Search this Thread Display Modes
  #1  
Old April 18th, 2019, 11:15 PM
Sam442's Avatar
Sam442 Sam442 is offline
 

Join Date: Apr 2019
Posts: 2
Likes : 0
Liked 0 Times in 0 Posts
Default Gauge issues

Hello, new to the forum. New to me 66 F100, 352, 3 on the tree.
Fuel and temp gauges read full scale. Performed continuity check from fuel sender to gauge. All good. Tested sender with ohm meter. All good. Cleaned grounds. With some searching and googling, I checked the voltage regulator on back of instrument panel. Was getting 12v in and 12v out. Picked up a new regulator (NPD 10 minutes from my house). 12v in, 8v out, gauges still pegged. Am I missing something? I read that the output is sweeping and I am using a digital multimeter. Any guidance on what else I could check would be much appreciated.
Thanks and looking forward to working on this thing!
  #2  
Old April 19th, 2019, 04:03 PM
JedCrone's Avatar
JedCrone JedCrone is offline
 

Join Date: Jul 2018
Location: Austin, Tx
Posts: 21
Likes : 0
Liked 3 Times in 3 Posts
Default

I'm having trouble with my '74 dash as well. Same symptoms. U have gone thru 3 different regulators. Maybe I just keep getting bad ones? I only have a digital multimeter too. This wont help but at least you know someone else is having the same problem
  #3  
Old April 22nd, 2019, 09:44 AM
harrison28's Avatar
harrison28 harrison28 is offline
 

Join Date: Mar 2015
Location: St. Cloud, Fl.
Posts: 1,315
Images: 23
Likes : 182
Liked 8 Times in 7 Posts
Default

A descent digital meter should read a "sweeping" voltage as well. I use a $500 Fluke, but I am an electrician by trade. You could get by with a cheaper Ideal meter or Klein even. Just something other then the $20 auto zone deal. If possible, get an aftermarket gauge and hook it up temporary to verify all the circuits are working properly. You can always return it. This could help narrow down where you're exact issue is.
  #4  
Old June 7th, 2019, 11:38 PM
Sam442's Avatar
Sam442 Sam442 is offline
 

Join Date: Apr 2019
Posts: 2
Likes : 0
Liked 0 Times in 0 Posts
Default

Sorry for not posting and following up. Been working out of town and haven’t had a chance to look into this for a while. Until today...... still have fuel and temp gauge issues after installing a new voltage regulator behind instrument panel. Fuel gauge goes full scale even with sender unplugged and not touching anything. Decided to pull instrument panel to have more access, and now I have lost ALL power. I mean nothing! All fuses are good on fuse panel. Is there a main fuse that could have blown somewhere?? Any assistance would be appreciated so I can continue troubleshooting the other issues.
  #5  
Old July 21st, 2019, 06:23 AM
RustyPile's Avatar
RustyPile RustyPile is offline
 

Join Date: Jul 2019
Posts: 4
Likes : 0
Liked 1 Time in 1 Post
Default

The gauges won't work if you're trying to check the gauges with the cluster removed from the dash until you establish a ground path.. Do this by using a jumper connected between ground circuit on the cluster and the body..
The Following User Likes This Post:
harrison28 (July 22nd, 2019)


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


(View-All Members who have read this thread : 8
glc , harrison28 , JedCrone , jheat , Losvws , RustyPile , Sam442 , Shanehib

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with gas gauge Jarhizzy 1993-1997 Ford Ranger
3 July 21st, 2013 10:10 PM
Engine Temp Gauge 88f150 1973-1991 Ford F150
3 June 19th, 2013 11:41 PM
Gas Gauge ames8722 1973-1991 Ford F150
9 August 28th, 2012 07:36 PM
Looking for: Bore gauge Klitch Garage Talk: The Tool Depot™ 4 June 26th, 2012 03:10 PM
Gas gauge issues nismo972 2004-2008 Ford F150
3 July 10th, 2010 09:39 PM

Tags
gauge , issues

Forum Jump









FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. Ford® is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.