Quantcast 92 F150 5.0 E4OD Not Shifting Code 625 - Ford Truck Club Forum




Home






Forum






Gallery






Garage






Blog






Arcade






Settings






New Posts






TOTM






Vote




Remember Me?
       Join for free!




Search






How-To's






Unanswered






FTC Toolbar






Social Sites






Register




 
Ford Truck Club Forum > FORD F-100 | F-150 SERIES > 1992-1996 Ford F150



Welcome to FordTruckClub.net
Welcome to FordTruckClub.net, the internet's premier Ford truck community! You are currently viewing our boards as a guest which gives you limited access to view discussions and access other forum features. By joining our free online community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple, and absolutely free so please, join our community today!

Forgot your password? click here.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

 
Thread Tools Search this Thread Display Modes
  #1  
Old June 8th, 2019, 07:43 PM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Unhappy 92 F150 5.0 E4OD Not Shifting Code 625

I am about ready to give up on this truck. Every time I fix one thing another problem pops up. OK, I had been fighting a parasitic battery drain and finally had the alternator rebuilt due to it testing bad (rectifiers were shorted). Any how the starter also went bad and I replaced it at the same time. I started it up and it was running like crap and dying intermittently. I pulled the codes, 334 was the only code. It finally got to the point that it would only start with the gas pedal to the floor and then it would sputter, backfire and die. Checked coil and a few of the plug wires for spark, they had spark. Backprobed the ICM to check for proper voltage on the PIP circuit, it was ok (4-5 volts during crank). Checked fuel injection pressure at the schrader (sp?) valve, pressure was good and held. Pulled one of the plugs, plug was fouled, very heavy carbon buildup. Pulled the remaining plugs and they were all in the same shape. Replaced plugs and plug wires, truck ran extremely rough at initial startup and smoked horribly. I'm assuming the truck running rough was due to the battery being disconnected and clearing all the computer memory and since I have the 334 code the computer is trying to compensate and relearn.

Anyhow, I took it for a short test drive. It definitely has better power now with the new plugs and wires but now it is not shifting into 3rd gear, I only have 1st and 2nd. Went home, pulled the codes. I now have the following codes, 625, 212, 334, and 337.

The one I am concerned with for now is the code 625 which is "Electronic Pressure Control Solenoid circuit fault". Does anyone have suggestions? I looked on RockAuto and they have a pressure control solenoid but I don't know if that is what is causing the shifting problem. I don't want to spend money if this would not fix the problem. Especially if I will have to end up swapping out the transmission.

92 F150 XLT 2WD 5.0 302 E4OD long bed
  #2  
Old June 8th, 2019, 10:03 PM
glc's Avatar
glc glc is offline
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,139
Likes : 2
Liked 112 Times in 108 Posts
Default

The 625 code points to a fault in the ECU, not necessarily the solenoid itself. Your other codes are also pointing at the ECU in addition to the EGR system.

Pull the ECU, open it up, and check for any evidence of burnt components. Check the connector and wiring too.

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS
  #3  
Old June 9th, 2019, 09:36 AM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Default

Thanks for the information, I will check the ECM.

I was wondering, When I started the truck up, it was smoking really bad so I am assuming that the smoke was from the transmission fluid being drawn into the engine and burned. Would the ECM have caused that?

92 F150 XLT 2WD 5.0 302 E4OD long bed
  #4  
Old June 9th, 2019, 12:24 PM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Default Posssible ECU Problem

I pulled the ECU and found two bad capacitors. I guess I need to find a good used one. I'll check some of the junkyards, any ideas on a good source if I can't find one locally?
Attached Thumbnails
Click image for larger version

Name:	ECU.jpg
Views:	35
Size:	243.8 KB
ID:	1539  

92 F150 XLT 2WD 5.0 302 E4OD long bed

Last edited by jheat; June 9th, 2019 at 01:21 PM. Reason: better update
  #5  
Old June 9th, 2019, 06:49 PM
glc's Avatar
glc glc is offline
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,139
Likes : 2
Liked 112 Times in 108 Posts
Default

Rock Auto has remans with 12 month/18k warranty. Much better bet than a junkyard unit.

https://www.rockauto.com/en/catalog/...computer),2896

Click the Info button to find out how to get the right ID.

The smoking is due to something other than the transmission, I'm not aware of any vacuum attached to the tranny.

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS
  #6  
Old July 17th, 2019, 07:29 PM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Default

I bought a reman from RockAuto and just installed it. now the truck will crank but not start and the relays are constantly clicking. Any idea how to start troubleshooting?

92 F150 XLT 2WD 5.0 302 E4OD long bed
  #7  
Old July 17th, 2019, 08:11 PM
glc's Avatar
glc glc is offline
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,139
Likes : 2
Liked 112 Times in 108 Posts
Default

Does it have the correct ID? What happens if you put the old unit back in?

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS
  #8  
Old July 17th, 2019, 08:45 PM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Default Relays constantly clicking

I just replaced the ECM in my 92 F150 with a reman from Rock Auto. (Just to clarify it was the correct one). I put the ECM in and now the truck cranks but will not start. Also, the relays just constantly click. I tried to hook up a code reader but the relays never stop clicking and it won't go into test mode. Any ideas on what steps I should take.

92 F150 XLT 2WD 5.0 302 E4OD long bed
  #9  
Old July 18th, 2019, 12:40 AM
glc's Avatar
glc glc is offline
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,139
Likes : 2
Liked 112 Times in 108 Posts
Default

I merged your 2 threads. Please keep everything in one thread for better continuity. Thanks!

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS
  #10  
Old July 18th, 2019, 06:32 AM
jheat's Avatar
jheat jheat is offline
 

Join Date: Nov 2018
Posts: 12
Likes : 0
Liked 0 Times in 0 Posts
Default

It is the correct ID. I will try the old one but it has blown capacitors so not sure that would tell me anything.

92 F150 XLT 2WD 5.0 302 E4OD long bed


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


(View-All Members who have read this thread : 59
67 Merc 4x4 , AlfredHof , Anthonysib , Bettybuiny , Billygenna , Bogdanyva , BrianRed , Charlesgrago , Danielfuh , Deannanob , DennisPoili , DennisTed , ErnikaOdowl , Eurosse , FrankCoosy , GeorgeEtela , glc , harrison28 , her , Jamesher , Jeffreytep , Jesseplosy , jheat , KeithFoult , Ken , Kennethdof , KevinDuels , LadonnaCen , LarryVab , LilaBar , MarioDit , MarioThoky , Martynaw , Michaelanify , Michaelrar , Mikaelhiz , nydon , Petrrarc , Pharmacevtmi , PollyTek , Ramonvog , Raymondagozy , RobertEmavy , Robertnut , RobertSnubs , RobertVog , RobertVoT , Rodneyvat , RonaldFon , Russellasymn , Shanehib , TimothyNut , TorqueO , TravisAvell , Wes , Williamidons , Williamsnort , XRumerTest , ZacharyThync

Similar Threads
Thread Thread Starter Forum Replies Last Post
AOD or E4OD? harrison28 Garage Talk: Engine & Drivetrain 6 January 14th, 2019 12:13 PM
e4od tranny shifting hard moemoe3 1992-1997 Ford F250 | F350
2 September 17th, 2014 11:48 PM
Speedometer & odometer off/ shifting hard LilBit 4x4 1992-1997 Ford F250 | F350
4 July 25th, 2013 07:43 PM
Truck shifting hard Monster 2004-2008 Ford F150
4 February 1st, 2013 03:19 AM
Shifting problem? russ94 2004-2008 Ford F150
3 February 11th, 2012 10:09 PM

Tags
625 , clicking , code , constantly , e4od , f150 , relays , shifting

Forum Jump









FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. Ford® is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.