Quantcast High idle - Ford Truck Club Forum




Home






Forum






Gallery






Garage






Blog






Arcade






Settings






New Posts






TOTM






Vote




Remember Me?
       Join for free!




Search






How-To's






Unanswered






FTC Toolbar






Social Sites






Register




 
Ford Truck Club Forum > FORD BRONCO | BRONCO II > 1987-1991 Ford Bronco



Welcome to FordTruckClub.net
Welcome to FordTruckClub.net, the internet's premier Ford truck community! You are currently viewing our boards as a guest which gives you limited access to view discussions and access other forum features. By joining our free online community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple, and absolutely free so please, join our community today!

Forgot your password? click here.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

 
Thread Tools Display Modes
  #1  
Old December 1st, 2014, 06:57 PM
Moore1991bronco's Avatar
Moore1991bronco Moore1991bronco is offline
 

Join Date: Nov 2014
Location: il
Posts: 4
Images: 1
Likes : 0
Liked 0 Times in 0 Posts
Default High idle

A pieced together motor in a 91' Ford Bronco, has A set of GT 40 heads off of a '96, 5.0 Ford Explorer, has a '96 5.8 EFI motor. It idles high at around 1500 RPMs, and when you give it gas, the RPMs go up but it takes a long time for them to fall back to 1500 after releasing the throttle. I recently put the GT 40 heads, new gaskets, and did an at-home port and polish on the heads. I can't figure out why it would be idling so high, because it didn't when I started this project. Any help is appreciated.
  #2  
Old December 1st, 2014, 10:44 PM
skatebowd's Avatar
skatebowd skatebowd is offline

 

Join Date: Jun 2011
Location: Cantonment Florida
Posts: 5,278
Images: 243
Likes : 14
Liked 32 Times in 32 Posts
Default

have you checked for vacum leak

click below to see my FTC Gallery


Don't forget those that came before you! Be proud of who you are and where your from.

“No damn man kills me and lives.” Confederate Lieutenant General, Nathan Bedford Forrest





  #3  
Old December 1st, 2014, 11:09 PM
Moore1991bronco's Avatar
Moore1991bronco Moore1991bronco is offline
 

Join Date: Nov 2014
Location: il
Posts: 4
Images: 1
Likes : 0
Liked 0 Times in 0 Posts
Default

I tried spraying brake cleaner around where I thought it might be sucking air
  #4  
Old December 3rd, 2014, 09:13 PM
Moore1991bronco's Avatar
Moore1991bronco Moore1991bronco is offline
 

Join Date: Nov 2014
Location: il
Posts: 4
Images: 1
Likes : 0
Liked 0 Times in 0 Posts
Default

Well I got it running like it should be it was a broke ear on the plenum and changed the gasket so it must have been sucking air where the ear was broke thank you for all the help
  #5  
Old December 4th, 2014, 01:27 PM
JSoko's Avatar
JSoko JSoko is offline

 

Join Date: Jun 2009
Location: Northwest Georgia
Posts: 14,923
Images: 620
Likes : 31
Liked 179 Times in 161 Posts
Default

I spray with water


For Those Who Fought For It...
Freedom Has A Taste The Protected Will Never Know.












  #6  
Old July 17th, 2018, 06:36 PM
TCBronc90's Avatar
TCBronc90 TCBronc90 is offline
 

Join Date: Jul 2018
Posts: 2
Likes : 0
Liked 0 Times in 0 Posts
Default

Is this the correct spot to ask a similar question about high idle? Thanks, TCBronc90
  #7  
Old July 17th, 2018, 11:30 PM
glc's Avatar
glc glc is offline
 

Join Date: Jul 2012
Location: Joplin MO
Posts: 1,088
Likes : 2
Liked 95 Times in 92 Posts
Default

We do prefer if you start a new thread in the appropriate forum. Thanks!

2003 F-150 XL RCSB 2wd 4.2 5 speed 3.55 LS


Thread Tools
Display Modes


(View-All Members who have read this thread : 10
Bigbluewindsor , cierrablea , glc , harrison28 , JSoko , Moore1991bronco , Russo2 , skatebowd , TCBronc90 , vjsimone

Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic Idle IrishKRO 1973-1991 Ford F150
11 September 9th, 2014 07:29 AM
High Idle to low idle dead spot Lostin90s 1992-1996 Ford F150
3 March 15th, 2013 09:45 PM
Egr , and idle solenoids. 2010Iron883 1973-1991 Ford F150
0 February 26th, 2012 12:01 PM
Looking for similar idle issue BigT67 1997-2003 Ford F150
11 June 14th, 2010 09:46 PM
idle rpm 95 5.0 chatterjj 1992-1996 Ford F150
3 January 3rd, 2010 08:38 AM

Tags
bronco , high , idle

Forum Jump









FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. Ford® is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.