Quantcast question about my expedition - Ford Truck Club Forum




Home






Forum






Gallery






Garage






Blog






Arcade






Settings






New Posts






TOTM






Vote








Search






How-To's






Unanswered






FTC Toolbar






Social Sites






Log Out




 
Ford Truck Club Forum > ALL OTHER FORD MODELS > Ford Expedition



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

 
Thread Tools Search this Thread Display Modes
  #1  
Old May 3rd, 2015, 05:13 PM
RhondaSue's Avatar
RhondaSue RhondaSue is offline
 

Join Date: May 2015
Posts: 1
Likes : 0
Liked 0 Times in 0 Posts
Question question about my expedition

Lately, when the temperature outside exceeds 90 degrees my expedition has no power upon acceleration. It feels like I'm pulling a heavy load. In fact, if my truck had emphysema that's how I would describe it. Once I get to speed out on the open highway everything is fine. This also happens when the temperature is below 32ish. Has anyone experience this and can anyone suggest a solution?

Thanks,

RhondaSue
  #2  
Old May 3rd, 2015, 06:28 PM
JSoko's Avatar
JSoko JSoko is offline

 

Join Date: Jun 2009
Location: Northwest Georgia
Posts: 15,064
Images: 630
Likes : 36
Liked 188 Times in 170 Posts
Default

an intro with some info as to year, engine, location, would be helpful

dang, I'll ask around
sounds kinda strange
? where ya from


For Those Who Fought For It...
Freedom Has A Taste The Protected Will Never Know.












  #3  
Old May 4th, 2015, 07:28 AM
JSoko's Avatar
JSoko JSoko is offline

 

Join Date: Jun 2009
Location: Northwest Georgia
Posts: 15,064
Images: 630
Likes : 36
Liked 188 Times in 170 Posts
Default

seems to be common
here's what I found



For Those Who Fought For It...
Freedom Has A Taste The Protected Will Never Know.













Last edited by JSoko; May 4th, 2015 at 07:32 AM.
  #4  
Old May 4th, 2015, 07:34 AM
JSoko's Avatar
JSoko JSoko is offline

 

Join Date: Jun 2009
Location: Northwest Georgia
Posts: 15,064
Images: 630
Likes : 36
Liked 188 Times in 170 Posts
Default

here's a good source for Expeditions

http://expeditionforum.com/


For Those Who Fought For It...
Freedom Has A Taste The Protected Will Never Know.













Last edited by JSoko; May 5th, 2015 at 08:17 AM.
  #5  
Old May 5th, 2015, 08:17 AM
JSoko's Avatar
JSoko JSoko is offline

 

Join Date: Jun 2009
Location: Northwest Georgia
Posts: 15,064
Images: 630
Likes : 36
Liked 188 Times in 170 Posts
Default

found this also

Technical Service Bulletin 02-12-03

• DRIVEABILITY—ENGINE LACKS POWER WHEN Article No.
OPERATING IN HIGH AMBIENT TEMPERATURES 02-12-3
ABOVE 38C (100F)—VEHICLES EQUIPPED WITH
5.4L ENGINE ONLY
• ENGINE—5.4L—ENGINE LACKS POWER WHEN
OPERATING IN HIGH AMBIENT TEMPERATURES
ABOVE 38C (100F)

PCM re-program


For Those Who Fought For It...
Freedom Has A Taste The Protected Will Never Know.












  #6  
Old June 29th, 2015, 10:37 AM
gwfan's Avatar
gwfan gwfan is offline
 

Join Date: Jun 2015
Location: Las Vegas, Nevada
Posts: 75
Likes : 3
Liked 0 Times in 0 Posts
Default

I haven't experienced that on my truck.


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


(View-All Members who have read this thread : 9
ASwaff400 , Flareside95 , glc , gwfan , harrison28 , JSoko , MetroD , RCGLMG , RhondaSue

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mods for a Expedition Ridgerunner Ford Expedition 9 February 17th, 2014 09:39 PM
97 expedition parts...? ASwaff400 Ford Expedition 1 May 1st, 2012 12:19 PM
new tires on the expedition ASwaff400 Garage Talk: Wheels & Tires 3 March 8th, 2011 10:04 PM

Tags
expedition , question

Forum Jump






   Current Advertisers Privacy Policy FAQ Home Blog Archive Top



FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. Ford® is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.