Quantcast Problem with gas gauge - Ford Truck Club Forum




Home






Forum






Gallery






Garage






Blog






Arcade






Settings






New Posts






TOTM






Vote




Remember Me?
       Join for free!




Search






How-To's






Unanswered






FTC Toolbar






Social Sites






Register




 
Ford Truck Club Forum > RANGER | MAZDA-B > 1993-1997 Ford Ranger



Welcome to FordTruckClub.net
Welcome to FordTruckClub.net, the internet's premier Ford truck community! You are currently viewing our boards as a guest which gives you limited access to view discussions and access other forum features. By joining our free online community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple, and absolutely free so please, join our community today!

Forgot your password? click here.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

 
Thread Tools Display Modes
  #1  
Old July 18th, 2010, 03:22 PM
Jarhizzy's Avatar
Jarhizzy Jarhizzy is offline
 

Join Date: Jul 2010
Location: Pittsburgh, Pa
Posts: 19
Images: 8
Likes : 0
Liked 0 Times in 0 Posts
Default Problem with gas gauge

Hello I own a 1994 Ford Ranger XLT 4X4 5 speed 4.0L. Owned the vehicle for about a month now and was wondering why my gas gauge does not work right. When the truck is off, the gauge shows the correct amount of gas in the truck. when i start and drive the truck, it shows empty. My thought is that the wires are on backwords some where or theres a ground issue so that when it is off, the gauge is on. Please let me know. its getting kinda annoying having to turn the truck off to see how much gas i have

Thanks, Ryan
  #2  
Old July 19th, 2010, 08:11 AM
JSoko's Avatar
JSoko JSoko is offline

 

Join Date: Jun 2009
Location: Northwest Georgia
Posts: 13,720
Images: 561
Likes : 23
Liked 122 Times in 103 Posts
Default

I used to just keep the tank full and watch my milage

my first thought was a hole in the float, but your guage does work

several things to check
It will be a PITA but you may have a bad ground for the instrimunt cluster; dissasemble the cluster from the dash and check the ground connection remove it and clean it with steel wool or a pincel eraser; this might help

or; you can remove the bed and check the sending unit connections which can accumulate all kind of trash, dirt, moisture, and harbor corroision; pull the connector apart and clean it and spray it with WD 40 and put it back together this may fix it

The fuel gauge and fuel sending unit are very easy to test and in about 15 minutes you will know exactly what's wrong.

First thing you need to do is check all the fuses and make sure you are getting power to the gauge. If the other gauges are working, then you can safely assume power is coming into the cluster (red/yellow wire).Then check the black/yellow wire at the fuel tank connector and make sure you have a good ground.

If power and ground are good, then ground the yellow/white wire at the fuel tank connector. If the fuel gauge goes all the way to FULL, you have a bad sending unit. If it stays at Empty, you have a bad gauge or an open in the yellow/white wire.

Ford has a special tester for the Anti-Slosh module. But if you replace the fuel level sending unit and fuel gauge, and assuming the wiring is indeed good, then it's a pretty good bet the Anti-Slosh module is bad.


heres how you can test the gauge itself, with a multi-meter
With the sending unit float arm in the empty stop position, resistance should be 15 ohms (below E). With the sending unit float arm in the full-stop position, resistance should be 160 ohms (above F). The fuel gauge should read empty at 22.5 ohms and full at 145 ohms.

for the sending unit:
With ohmmeter positive lead on the signal wire lead and the negative lead on ground, check the resistance values of the fuel sending unit at various positions of the float arm. An open circuit will indicate infinity on the ohmmeter and a short will indicate zero ohms.

for a bad harness connector: check resistance from harness connector back to PCM. you"ll need a wiring diagram; which can be had in a Haynes or Chilton Manual

the bed isn't hard to take off, just get extra help so you don't scratch it

good luck as these type of problems can be an exstream PITA


For Those Who Fought For It...
Freedom Has A Taste The Protected Will Never Know.











Last edited by JSoko; July 19th, 2010 at 03:54 PM.
  #3  
Old July 19th, 2010, 07:12 PM
BigT67's Avatar
BigT67 BigT67 is offline
 
Join Date: Jun 2009
Location: Hoquiam, WA
Posts: 3,532
Images: 258
Likes : 7
Liked 1 Time in 1 Post
Default

Quote:
Originally Posted by jsoko View Post
I used to just keep the tank full and watch my milage

My dad used to do that for a 1970 chevy van he had. He kept a shirt pocket sized tablet and pencil on the dash and made sure he watched the odometer. He bought the van new for a race bike hauler and shortly after the gauge quit. He did the math for the next 18 years until it got parked and just rotted into the ground......


Big T



Friends help you move. Real friends help you move bodies.



  #4  
Old July 21st, 2013, 10:10 PM
Budberry's Avatar
Budberry Budberry is offline
 

Join Date: Jul 2013
Posts: 3
Likes : 0
Liked 0 Times in 0 Posts
Default

I'm having the same problem with my 1997 f250. I am going to fill up and watch the mileage. I took the instrument cluster out and found no anti sloosh module. My next move is to take the bed off and see if the sending unit is stuck. The gauge moves to the resting position when the truck is off but only rises to one line above E. oh well could be worst I could own a Dodge


« 1994 ranger no start | There is no next thread »
Thread Tools
Display Modes


(View-All Members who have read this thread : 9
ames8722 , bikertrash3531 , Brianc , Budberry , gjohns17 , glc123 , Russo2 , scbill , shayrun

Similar Threads
Thread Thread Starter Forum Replies Last Post
tailgate problem tam85 2011-2014 Ford F250 | F350
8 November 6th, 2013 09:03 AM
Gas gauge issues nismo972 2004-2008 Ford F150
3 July 10th, 2010 09:39 PM
Gauge Opinions Needed nine5flareside 1992-1996 Ford F150
17 May 3rd, 2010 08:19 PM
04-05 Spark Plug Problem 2004FX4F150 Garage Talk: Paint & Detailing 3 March 10th, 2010 03:35 PM
Strange HID problem 2004FX4F150 2004-2008 Ford F150
20 February 22nd, 2010 06:29 PM

Tags
gas , gauge , problem

Forum Jump









FordTruckClub.net is not authorized, endorsed or affiliated with the Ford Motor Company
or any of their subsidiaries. Ford® is a registered trademark of the Ford Motor Company


Powered by vBulletin® Version 3.8.6 Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.